Introduction:


Sometimes TV viewers experience that a TV service goes black (no video) in the middle of a transmission.

Audio may also be affected, or it can be no audio, but video is OK. 

Zapping to another channel and back again, fixes the problem. Few TV sets or STBs need to do a new 

channel scanning to get back to working order.


Cause:

TV Operators sometimes change their audio and/or video PID (Packet IDentifier) allocation on the fly.
This can be for very good reasons, such as upgrading from an SD to an HD stream, adding or changing 

audio tracks, or it can happen by accident, when fiddeling with their playout.


According to the DVB Protocol such changes shall be handled automatically by the client (TV set or STB), 

but the implementation can be very different from TV to TV. Consequently, what the viewers experience 

and see can also be different. See the following 3 types of unit behaviour:


a) Most newer TV sets and STBs are in a position to monitor and react correctly to such changes on the 

    fly, and no visible change or problem will be seen by the user.


b) A few newer TV sets or STBs and a fair number of older ones does not monitor PID changes during
    transmission, and only monitor and react to them during a channel change. Users see black screen.


c) A minority of TV sets or STBs (typically older ones) only record PIDs from the services during initial
   channel scanning, and stobbornly uses the PID data from the channel scan in all further actions.
   Consequently such TV sets or STBs will loose services when the operator changes PIDs.


Fix:

a) No action needed. The TV set or STB handles everything automatically and on the fly. The user
    sees no interruption or problem.

b) The user need to zap to another channel and back again, and the PID changes will be picked
    up and handled and all TV services are OK again. 

c) A channel change does not fix anything. The User must do a new channel scanning on the TV
   or STB to pick up and store all PID changes. 


NOTE:

Including TDX SW V3, PID changes could happen when rebooting, or by changes in the configuration. 

Hence, such changes often caused all users having type c) TV sets or STBs referred above, to require a 

new channel scanning to re-activate all channels.


Since TDX SW V4 (TDX Black Edition) Fixed and PID-remapping is implemented. TDX reboots are safe
and does NOT change any PIDs. Beware though, that fiddeling with the configuration (adding or
removing services) MAY change PIDs, in which case type c) TV sets or STBs will have to do a channel
re-scan.


When such TDX configuration changes are scheduled to happen often, we recommend to activate 

the PID-Remapping License of the TDX SW V4,that has the added benefit of letting the Installer fix
or manipulate any PIDs in the system. Consequently all PID changes caused by operators or the 

TDX can be manually edited by the installer so users does not experience any changes on the
output side. This new V4 feature alone is a VERY good reason to upgrade the SW of any TDX
active unit running an older SW version.


It is important to understand, that PID changes are NOT an error. Operators are in their full right to

mess with them. Any user problems triggered by this most often are caused by TV sets or STBs not 

fully complying to the DVB Protocol. This can be by both mistake, ignorance, cost or low resources
(or a mix of all) in the TV set or STB.